Joomla Update Blog

Most if not all issues with Joomla installations have to do with not timely update your Joomla version, below you will find the standard Security RSS feed of Joomla; these are only the updates you may need for the CORE of the software, not for any additional plugins you may have installed. It is important to always check your CORE Joomla files but do not forget your added components or plugins. Also always remove any unused components, themes or plugins for any installation (Joomla or any other software product).

\r\nProject: Joomla!\r\nSubProject: CMS\r\nSeverity: High\r\nVersions: 3.7.0\r\nExploit type: SQL Injection\r\nReported Date: 2017-May-11\r\nFixed Date: 2017-May-17\r\nCVE Number: CVE-2017-8917\r\n\r\nDescription\r\nInadequate filtering of request data leads to a SQL Injection vulnerability.\r\nAffected Installs\r\nJoomla! CMS versions 3.7.0\r\nSolution\r\nUpgrade to version 3.7.1\r\nContact\r\nThe JSST at the Joomla! Security Centre.\r\nReported By: Marc-Alexandre Montpas / sucuri.net
\r\nProject: Joomla!\r\nSubProject: CMS\r\nSeverity: Low\r\nVersions: 3.4.0 through 3.6.5\r\nExploit type: Information Disclosure\r\nReported Date: 2016-Feb-06\r\nFixed Date: 2017-April-25\r\nCVE Number: CVE-2017-8057\r\n\r\nDescription\r\nMultiple files caused full path disclosures on systems with enabled error reporting.\r\nAffected Installs\r\nJoomla! CMS versions 3.4.0 through 3.6.5\r\nSolution\r\nUpgrade to version 3.7.0\r\nContact\r\nThe JSST at the Joomla! Security Centre.\r\nReported By: Sim of tencent security
\r\nProject: Joomla!\r\nSubProject: CMS\r\nSeverity: Low\r\nVersions: 3.2.0 through 3.6.5\r\nExploit type: ACL Violation\r\nReported Date: 2017-March-01\r\nFixed Date: 2017-April-25\r\nCVE Number: CVE-2017-7989\r\n\r\nDescription\r\nInadequate mime type checks allowed low-privilege users to upload swf files even if they were explicitly forbidden.\r\nAffected Installs\r\nJoomla! CMS versions 3.2.0 through 3.6.5\r\nSolution\r\nUpgrade to version 3.7.0\r\nContact\r\nThe JSST at the Joomla! Security Centre.\r\nReported By: Abdullah Hussam
\r\nProject: Joomla!\r\nSubProject: CMS\r\nSeverity: Low\r\nVersions: 1.6.0 through 3.6.5\r\nExploit type: ACL Violation\r\nReported Date: 2016-April-29\r\nFixed Date: 2017-April-25\r\nCVE Number: CVE-2017-7988\r\n\r\nDescription\r\nInadequate filtering of form contents lead allow to overwrite the author of an article.\r\nAffected Installs\r\nJoomla! CMS versions 1.6.0 through 3.6.5\r\nSolution\r\nUpgrade to version 3.7.0\r\nContact\r\nThe JSST at the Joomla! Security Centre.\r\nReported By: T-Systems Multimedia Solutions
\r\nProject: Joomla!\r\nSubProject: CMS\r\nSeverity: Low\r\nVersions: 3.2.0 through 3.6.5\r\nExploit type: XSS\r\nReported Date: 2016-February-28\r\nFixed Date: 2017-April-25\r\nCVE Number: CVE-2017-7987\r\n\r\nDescription\r\nInadequate escaping of file and folder names leads to XSS vulnerabilities in the template manager component.\r\nAffected Installs\r\nJoomla! CMS versions 3.2.0 through 3.6.5\r\nSolution\r\nUpgrade to version 3.7.0\r\nContact\r\nThe JSST at the Joomla! Security Centre.\r\nReported By: David Jardin
\r\nProject: Joomla!\r\nSubProject: CMS\r\nSeverity: Low\r\nVersions: 1.5.0 through 3.6.5\r\nExploit type: XSS\r\nReported Date: 2017-February-22\r\nFixed Date: 2017-April-25\r\nCVE Number: CVE-2017-7986\r\n\r\nDescription\r\nInadequate filtering of specific HTML attributes leads to XSS vulnerabilities in various components.\r\nAffected Installs\r\nJoomla! CMS versions 1.5.0 through 3.6.5\r\nSolution\r\nUpgrade to version 3.7.0\r\nContact\r\nThe JSST at the Joomla! Security Centre.\r\nReported By: Fortinet\'s FortiGuard Labs
\r\nProject: Joomla!\r\nSubProject: CMS\r\nSeverity: Low\r\nVersions: 1.5.0 through 3.6.5\r\nExploit type: XSS\r\nReported Date: 2017-March-21\r\nFixed Date: 2017-April-25\r\nCVE Number: CVE-2017-7985\r\n\r\nDescription\r\nInadequate filtering of multibyte characters leads to XSS vulnerabilities in various components.\r\nAffected Installs\r\nJoomla! CMS versions 1.5.0 through 3.6.5\r\nSolution\r\nUpgrade to version 3.7.0\r\nContact\r\nThe JSST at the Joomla! Security Centre.\r\nReported By: Fortinet\'s FortiGuard Labs
\r\nProject: Joomla!\r\nSubProject: CMS\r\nSeverity: Low\r\nVersions: 3.2.0 through 3.6.5\r\nExploit type: XSS\r\nReported Date: 2016-December-23\r\nFixed Date: 2017-April-25\r\nCVE Number: CVE-2017-7984\r\n\r\nDescription\r\nInadequate filtering leads to XSS in the template manager component.\r\nAffected Installs\r\nJoomla! CMS versions 3.2.0 through 3.6.5\r\nSolution\r\nUpgrade to version 3.7.0\r\nContact\r\nThe JSST at the Joomla! Security Centre.\r\nReported By: Chen Ruiqi, Codesafe team
\r\nProject: Joomla!\r\nSubProject: CMS\r\nSeverity: Low\r\nVersions: 1.5.0 through 3.6.5\r\nExploit type: Information Disclosure\r\nReported Date: 2017-Jan-02\r\nFixed Date: 2017-April-25\r\nCVE Number: CVE-2017-7983\r\n\r\nDescription\r\nMail sent using the JMail API leaked the used PHPMailer version in the mail headers.\r\nAffected Installs\r\nJoomla! CMS versions 1.5.0 through 3.6.5\r\nSolution\r\nUpgrade to version 3.7.0\r\nContact\r\nThe JSST at the Joomla! Security Centre.\r\nReported By: Conor McKnight
\r\nProject: Joomla!\r\nSeverity: High\r\nVersions: 1.5.0 through 3.6.5\r\nExploit type: Remote Code Execution in third-party PHPMailer library\r\nCVE Numbers: CVE-2016-10033 and CVE-2016-10045\r\n\r\nNote: This advisory was revised to reflect the addition of CVE-2016-10045 and the PHPMailer 5.2.20 release\r\nDescription\r\nAll versions of the third-party PHPMailer library distributed with Joomla! versions up to 3.6.5 are vulnerable to a remote code execution vulnerability. This is patched in PHPMailer 5.2.20 which will be included with Joomla! 3.7. After analysis, the JSST has determined that through correct use of the JMail class, there are additional validations in place which make executing this vulnerability impractical within the Joomla environment. As well, the vulnerability requires being able to pass user input to a message\'s \"from\" address; all places in the core Joomla API which send mail use the sender address set in the global configuration and does not allow for user input to be set elsewhere. However, extensions which bundle a separate version of PHPMailer or do not use the Joomla API to send email may be vulnerable to this issue.\r\nGenerally, the Joomla project does not issue advisories regarding third party libraries, however given the severity of this issue we felt it important to advise our users that we are aware of this issue and we have determined that the additional validations in our API prevent triggering this vulnerability.\r\nAffected Installs\r\nJoomla! CMS versions 1.5.0 through 3.6.5\r\nSolution\r\nNo action required for Joomla users, the updated library will be included in the next scheduled release and additional mechanisms exist in Joomla core to prevent triggering the vulnerability. Users of the PHPMailer library separate from Joomla are advised to upgrade to 5.2.20 or newer ASAP.\r\nAdditional Resources\r\n\r\nhttps://legalhackers.com/advisories/PHPMailer-Exploit-Remote-Code-Exec-CVE-2016-10033-Vuln.html\r\nhttps://legalhackers.com/advisories/PHPMailer-Exploit-Remote-Code-Exec-CVE-2016-10045-Vuln-Patch-Bypass.html\r\nhttps://github.com/PHPMailer/PHPMailer/blob/master/SECURITY.md\r\nhttps://github.com/PHPMailer/PHPMailer/wiki/About-the-CVE-2016-10033-and-CVE-2016-10045-vulnerabilities\r\n\r\nContact\r\nThe JSST at the Joomla! Security Centre.\r\nReported By: Dawid Golunski